Functionality Issue – Support telephone system
Incident Report for Imperva
Resolved
The support telephone system is fully operational.
Posted Oct 09, 2017 - 17:37 UTC
Identified
We have identified functionality issues with the support telephone system. Clients may be unable to reach Incapsula support via telephone.
Posted Oct 09, 2017 - 16:52 UTC